Author Topic: AGILITY 50F CDI prob  (Read 143 times)

Spiros Kir

  • Newbie
  • *
  • Posts: 2
    • View Profile
AGILITY 50F CDI prob
« on: October 12, 2017, 02:38:46 AM »
Hi All,

New to the forum but I have read many posts  from time to time that help me troubleshoot various issues with my agility.

So problem is one night I left my scoot in garage and next morning was dead -no spark.
Troubleshoot and found cdi is dead.
Scoot is 2008 with 20.000klm

My fear is if it is a common fault due to aging,klm etc or should I check why it got burn?
Measurements in ignition cabling, strator were ok.
Only notes were 
a)Spark plug and cable was at 16KΩ which I solved by clearing  the screw and bit at the end of the cable and now back in margin at 8KΩ.
b)battery is 4,5y old and a bit swollen on the sides, not gonna hold this winder.

I checked with Kymco and original CDI is at 60euros.
Should I buy a cheaper alternative or will I have probs? any good suggestions?

Thanks!! :D



JJJoseph

  • Full Member
  • ***
  • Posts: 244
  • Kymco Sento
    • View Profile
Re: AGILITY 50F CDI prob
« Reply #1 on: October 13, 2017, 01:40:35 AM »
CDIs are cheap and useful.  I have a boxful that I use for driving/testing, etc.  Don't pay more than $15-$20 per.  Some, like the yellow case one shown in the photo are totally excellent, better than the original.  The others work OK, but they're not as good.
« Last Edit: October 13, 2017, 01:42:07 AM by JJJoseph »

Spiros Kir

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: AGILITY 50F CDI prob
« Reply #2 on: October 18, 2017, 02:23:58 PM »
Thanks for reply!

To be honest I bought a used original  for 40e as from ebay I had to wait like 2weeks.

Can you tell me the brand of the yellow you mentioned?
Is it good in all weather, hot-warm-cold?

Thanks!